
Open GIS tools & 
mapping your data



Carl Zimmerman, PhD
Ashley Benitez
CT GIS Office
Carl.Zimmerman@ct.gov
Ashley.Benitez@ct.gov

Note: 
Part 1 of a 2-part series (May 1st, 1 pm)
Contact us if you want to discuss GIS data, 
policy, software, analysis, or visualization 
of data
GIS Software Reference Sheet available

What tutorial topics do you want?
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Introduction

mailto:Carl.Zimmerman@ct.gov
mailto:Ashley.Benitez@ct.gov
https://s.uconn.edu/webinar_opendata


Basic geospatial model

• Data stacks in a 
geographic coordinate 
system

• Often represents 
physical entities or 
models the RW

• Flexible data types

https://saylordotorg.github.io/text_essentials-of-geographic-information-systems/index.html



GIS software is a spatially-enabled database
• Each record 

corresponds to a 
location or point

• You can query the 
database

• New information
• Large scale

• No analysis or scale 
limits 

• Aggregation to any 
geography

• Visualization
• Model’s reality
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DB/Table Map



Typical workflow
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Open 
data

Geodata

Web 
service

(Geo) process data (Geo) process data Visualize in Map

Download data OR
Web mapping 
Services

Chain of processing Symbolize

GIS Software(Open) Data Map



Symbiosis between data types 
and data tools
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GIS data 
types



What are the basic GIS data types?

GIS data
• Location data with geographic 

coordinates
• Vector:

• Point, line, polygon
• Lidar point cloud
• Shape file, fc, geoJSON

• Not just shape files!
• Raster

• Aerial and satellite images
• Elevation surface
• Geotiff, .tif, many others

• Non-spatial to spatial (geocoding and 
chloropleths)

• Delivered via web services or download
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What are the basic GIS data types?

Vector
• Each point has a specific position
• Primitives are point, line, and polygon
• Location data with geographic coordinates
• Examples:

• Point, line, polygon
• Lidar point cloud
• Shape file, fc, geoJSON

• Often created via digitizing, feature extraction, 
or geocoding

• Delivered via web services or download

.

Raster
• Matrix positioned in space
• Primitives are called pixels, cells, or a grid

• Essentially a surface
• Examples

• Aerial and satellite images
• Elevation surface
• Geotiff, .tif, many others

• Typically derived from imagery or DEM
• Often created via interpolation or conversion
• Delivered via web services or download
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Critical: Different set of tools utilized for each data type



Vector data 
compared to 
raster data

9Found at: https://worldbank.github.io/OpenNightLights/tutorials/mod5_3_vector_and_raster_data.html



Imagery 
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Aerial imagery from the 2023 capture
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OpenStreetMap (Vector)

Basemap data set from OpenStreetMaps



3d bldg. footprints from 2023 capture

2023 imagery2 bldg. footprints from 2023 capture



Lidar Data
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Lidar point cloud of Bridgeport



Vector or raster? Image intensity data set
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Acquisition 
of data



Acquiring data: 
Download vs web 
services
• Download keeps data in a single 

structure (locally)
• Web services pull data from 

server using specific protocol
• Typ. authoritative, light, up-to-date 

• Variety of formats. 
• Tiles and vector services

• User finds a web mapping URLs 
as well as tabular URLs

• Web Mapping Services: An Introduction
• QGIS and WMS
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https://gisgeography.com/web-mapping-services-wms/


Where do I get data?

• CT Geodata Portal
• Data, services, 

features, mostly 
spatial
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Download or web services or both

https://geodata.ct.gov/


Where do I get data?

• CT Eco 
Aerial, 
Imagery and 
Lidar 
Download

• Data 
download 
site for 
imagery and 
Lidar
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https://maps.cteco.uconn.edu/download/
https://maps.cteco.uconn.edu/download/
https://maps.cteco.uconn.edu/download/
https://maps.cteco.uconn.edu/download/
https://maps.cteco.uconn.edu/download/


Where do I get data?

• CT Open Data
• Mostly tabular
• Data with 

geographies or 
addresses can be 
converted to 
spatial data
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Download or web services or both

https://data.ct.gov/


Where do I get data?

• Data.gov
• Geoplatform
• Living Atlas of the 

World
• Web services
• Numerous free 

services scaped or 
contributed from 
governments, 
academy, and non-
profits

• Federal agencies, 
states, regional 
planning agencies, 
towns
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https://data.gov/
https://www.geoplatform.gov/
https://livingatlas.arcgis.com/en/home/
https://livingatlas.arcgis.com/en/home/
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Software



Typical workflow
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Open 
data

Geodata

Web 
service

(Geo) process data (Geo) process data Visualize in Map

Download data OR
Web mapping 
Services

Chain of processing Symbolize

GIS Software(Open) Data Map



GIS software overview

• Works within a GIS community 
system

• Key tasks: 
• Maps and visualization, digital 

twins and simulation, analysis, and 
statistics, data management and 
automation, mapping services, 
analysis

• Commercial vs. open source
• Ex. ESRI is biggest vendor, but can 

be expensive
• World of open GIS software 

allows free access and usage
• Rise of data science has 

hybridized GIS and data science 
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https://stratoflow.com/what-is-gis/



Types of GIS software
• Stand alone “reader” tools’ 

(free)
• QT Reader
• FugroViewer
• Pyramid Shader 
• ET Spatial Data Viewer

• Quickly check out tiles for 
viewing and manipulation

• Best for manipulation of one 
tile
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FugroViewer Download
QT Reader Download

https://www.fugro.com/expertise/other-expertise/fugroviewer
https://appliedimagery.com/download/


FugroViewer Demo: Lidar and Imagery
• CT Eco download tool
• QT Reader or 

FugroViewer
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Simple 
Vector 
Reader

ET SpatialData 
Viewer
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https://www.ian-ko.com/Downloads.html


Vector and 
Raster 
“Light” GIS

OpenJump GIS
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https://www.openjump.org/


Desk stop software: QGIS
• GIS desktop applications

• ArcGIS Pro (paid, $100 for personal)
• QGIS (free)

• Desktop oriented – some limited 
web mapping capabilities

• Combine visualization and analytic 
functions

• Use to try out processes, 
experiment with data

• Single best choice for processing, 
viewing, and analyzing GIS data

• (ArcGIS Pro alternative)
• Mac/Linux, Windows, Android / 

Google
• Can be utilized with other code
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Download QGIS Long Term Version/

QGIS Training Manual 
QGIS Tutorials

https://qgis.org/download/
https://docs.qgis.org/3.40/en/docs/training_manual/index.html
https://www.qgistutorials.com/en/
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Desktop software: Grass GIS
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Grass GIS for Windows/

https://grass.osgeo.org/download/


Desktop software: Whitebox Software
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Whitebox
Plugs into Pro
or QGIS

https://www.whiteboxgeo.com/


Not quite free, ArcGIS Pro
• Personal use
• Advanced License
• Pro plus
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https://www.esri.com/en-us/arcgis/products/arcgis-for-personal-use/buy


Takes anything: gvSig Destktop
• Highly interoperable

• CAD , remote sensing, db, 
variety of web services

• gvSig Desktop Download
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https://www.osgeo.org/projects/gvsig/


Limited AGOL (ArcGIS Online)
• Make basic web maps
• ArcGIS Online Public Account
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https://community.esri.com/t5/arcgis-online-public-account-community/arcgis-online-public-accounts-getting-started/ba-p/1305110#:%7E:text=For%20those%20new%20to%20ArcGIS,GIS%20users%20around%20the%20world.


• Complicated
• Flexible and reliable
• Repeatable
• Growing
• Interoperable and linkable
• Often used in conjunction 

with commercial tools and 
underlies them

• Used in modern data science
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Scripting 
Tools



Anaconda
• Open-source software 

characteristics
• Open and transparent 

code base
• Updated continuously
• Collaborative/community 

developed
• Organizes Python and R 

packages (really 
powerful!) and has 
updates ready for you 
(which is really 
important!)

• Greatly simplifies loading 
and organization 
process
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IDEs and Notebooks
• Jupyter notebooks • Spyder IDE
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Types of GIS software
• Scripting (free)

• Python (Geopandas, numpy, 
pandas)

• R (tidy, ggplot2 or leaflet) 
ecosystems

• Notebooks

• Allows for automation and 
workflow creation. Use when 
you need to repeat the process 
or integrate with other 
packages

• Lot of flexibility from source to 
output

• Scientific computing

https://qgis.org/download/



Python GIS 
Libraries

• Geopandas/shapely-vector and 
overlay

• Rasterio-raster data
• GDAL-translation and conversion
• PyProj-projection
• Pandas/Numpy-statistics and 

munging
• Folium/ipyleaflet-interactive 

mapping in notebook
• PySAL-spatial statistcs
• ArcGIS API for Python (ArcPy)- 

automation of ArcGIS tasks, data 
management
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Found at: https://forrest.nyc/geospatial-needs-to-be-defined/

37 Python Packages You Need for GIS

https://forrest.nyc/the-37-geospatial-python-packages-you-definitely-need/
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R and GIS libraries
• Sf package – overlay and 

other vector functions
• ggplot2 or leaflet –mapping
• Raster / rasterio/ rgdal- 

working with raster data 
• Tidyverse- group of data 

science / visualization 
libraries know for their logic 
and ease of use

Tutorials and Background
TidyVerse and Data Science
Making Maps in R
Crash Course in R
Raster Data and R
GeoComputation in R
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https://www.tidyverse.org/packages/
https://rpubs.com/jdlecy/making_maps_in_r
https://bookdown.org/michael_bcalles/gis-crash-course-in-r/
https://www.neonscience.org/resources/learning-hub/tutorials/raster-data-r
https://r.geocompx.org/intro


Simple R 
Map

https://www.geeksforgeeks.org/making-maps-with-r/ 42



Types of GIS software
• Web mapping and 

dashboards
• ArcGIS Online (free personal 

use/paid)
• Tableau / Power BI (paid/free)
•  Dropchop.io (free web GIS)
• Flexdashboard/Tidyverse

• R dashboard variants
• leaflet

• Web mapping is the least  
open-source friendly IMO
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Web Mapping Servers
• Management software for 

deliver of web services
• Mapserver -delivers images of 

maps, relatively light
• Geoserver- supports 

transactional editing, more 
file formats

• Create web mapping services 
that can deliver content to 
users on websites

• Like ArcGIS Enterprise and 
AGOL
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https://mapserver.org/introduction.html
https://geoserver.org/


Brief Demos

45



QGIS Demo
• Basemaps
• Opening data from different sources

• ArcGIS Rest Servers
• GeoJSON

• Working with vector data 
• Attribute data
• Quick spatial analysis

• Layouts (export maps as PDF or images)

46
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QGIS Demo

A project is a container for all your 
map layers, properties, layouts, etc.

• Stores your layers, styles, 
coordinate systems, and 
symbology

• Keeps track of data paths (local 
files, services, URLs)

• Saves print layouts, labeling 
settings, and forms

• Lets you return to your work 
exactly as you left it

One project file = your workspace
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QGIS Demo

Ready-to-use 
XYZ Tiles 
services 
= Basemaps

https://docs.qgis.org/3.40/en/docs/user_manual/managing_data_source/opening_data.html#using-xyz-tile-services 

https://docs.qgis.org/3.40/en/docs/user_manual/managing_data_source/opening_data.html#using-xyz-tile-services
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QGIS Demo
Ready-to-use XYZ Tiles 
services 

Plugin QuickMapServices
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QGIS Demo
Load data from Web Sources:

Imagery
1. Go to: 
https://maps.cteco.uconn.edu/
map-services/ 

2. Get link: 
https://cteco.uconn.edu/ctrast
er/rest/services/ 

3. In QGIS:
• Layer > Add Layer > ArcGIS 
REST Server

• Click New
• Name: CT Raster Server
• URL: Paste link
• Click OK
• Click Connect
• Explore datasets!

https://maps.cteco.uconn.edu/map-services/
https://maps.cteco.uconn.edu/map-services/
https://cteco.uconn.edu/ctraster/rest/services/
https://cteco.uconn.edu/ctraster/rest/services/
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QGIS Demo

Load data from Web Sources:

Vector data: GEOJSON
Municipal Boundaries
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QGIS Demo

Load data from Web Sources:

Vector data: ArcGIS REST Service 
Parcel Layer
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QGIS Demo

Working with Vector Data:

Queries on attributes
Which parcels have a total 
assessed value higher/lower 
than or equal to X?

Which parcels are owned by X?
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QGIS Demo

Working with Vector Data:

Spatial analysis
How many households are 
within a 1-mile radius of 
each pharmacy?

Load pharmacies dataset 
(GeoJSON) from CT Open 
Data
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QGIS Demo
Working with Vector Data:

Spatial analysis
How many households are within 
a 1-mile radius of each pharmacy?

1. Create buffer
• Vector > Geoprocessing Tools > 
Buffer

• Distance: 1 mile
• Don't dissolve

2. Intersect (Select by location)
• Vector > Research Tools > 
Select by Location

• Features from: Tracts
• Compare to: Buffers

3. Export, symbolize, or analyze 
further data from those blocks! Census data from:  IPUMS National Historical Geographic Information System (NHGIS)
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QGIS Demo
Working with Vector Data:

Spatial analysis
How many households are within a 
1-mile radius of each pharmacy?

1. Open tract data attribute table 

2. Field Statistics 
• Right click on the housing counts 
field

• **Ensure you're applying it to 
selected features only**

3. View the sum of housing units

Census data from:  IPUMS National Historical Geographic Information System (NHGIS)
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QGIS Demo
Working with Vector Data:

Spatial analysis
How many pharmacies are within 1-
mile radius of each census tract?

1. Processing (Toolbox):
• Join Attributes by Location 
(Summary)

• Input layer: Census Tracts
• Join layer: Pharmacy Buffers (1-
mile buffer layer)

• Choose Intersects
• Summaries to calculate: Check 
Count only

• Run

Census data from:  IPUMS National Historical Geographic Information System (NHGIS)
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QGIS Demo
Creating Static Maps:

Layouts

1. Create a Layout
• Project > New Layout > “Name”

2. Add your map
• Add item> Add Map > Draw 
Extent in Layout

3. Add a legend
• Add item > Add Legend 
• Edit!

4. Export
• Project > Export as …



Places to learn
• Interagency GIS (03/19/25)
• YouTube Videos
• ESRI
• QGIS Tutorials
• Academic Libraries

• Brown University
• Tufts University
• University of Minnesota

• Library of Congress
• CT Geodata Portal and others
• Udemy, Coursera
• Call CT GIS Office

59

https://www.esri.com/training/catalog/search/filter/Web%20Courses/
https://courses.spatialthoughts.com/introduction-to-qgis.html
https://libguides.brown.edu/gis_data_tutorials/intro_qgis
https://sites.tufts.edu/gis/learning-gis/online-tips-and-tutorials/
https://libguides.umn.edu/geospatialdata
https://guides.loc.gov/geospatial
https://geodata.ct.gov/pages/resources


Questions???
• CT GIS Office

• Carl.Zimmerman@ct.gov
• Ashley.Benitez@ct.gov

• What tutorial topics do you want?
• Send us an email totalk about 

your ideas, projects, data, 
planning…
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